Recommended browsers for library databases

Please see below for information on minimum web browser requirements for three of our major database providers:

EBSCO

GALE

PROQUEST

NOTE: Microsoft’s new browser, Edge, is NOT officially supported by these providers, so users may encounter display and other issues when using the Edge browser with library databases; users may wish to switch to one of the supported browsers listed in these links if they encounter issues.